EAP 142.4859.6 module dependencies not checked

After updating to the latest EAP, changes in one module are not being reflected in another. For instance, new api or broken code will not affect the module that depends on it. All modules, entire project is maven based. Worked fine so far.

Right now I have to recompile the whole thing with maven on the command line first to get the changes reflected in all the modules. Some shenanigans with sources / paths / .. or something?

Windows 10 x64.

Thanks.

2 comments
Comment actions Permalink

If I add the module dependencies by hand through the module settings then it works. But if I re-import maven module than those modules disappear from the dependecies list from the module.

Module dependecies are then replaced by maven artficates of these modules in the local repo. Screws up the project.

0
Comment actions Permalink

Removing all modules from the project then creating a new project as maven, re-importing all of them back solved the issue. Now modules show in the dep-s list and do not get removed upon re-import.

Some change of IDEA control (iml, idea) files in the latest update? Or just a hickup.... Either way it works now, so as far as this EAP goes, it is solved.

0

Please sign in to leave a comment.