Duplicate Entry?

I'm trying to get webapps going as I've been stuck with 977 for some time
now. Sadly I don't seem to be able to get them to work with the latest EAP
either.

I'm getting the following error during compilation:

Error: duplicate entry: WEB-INF/classes/blah blah/AccessRight.class

I've hunted all morning but I can't find out what I'm doing wrong. Anyone
able to help? For the moment I'm switching back to 977.

Regards,

Glen



3 comments
Comment actions Permalink

Glen Stampoultzis wrote:

I'm trying to get webapps going as I've been stuck with 977 for some time
now. Sadly I don't seem to be able to get them to work with the latest EAP
either.

I'm getting the following error during compilation:

Error: duplicate entry: WEB-INF/classes/blah blah/AccessRight.class

I've hunted all morning but I can't find out what I'm doing wrong. Anyone
able to help? For the moment I'm switching back to 977.


1- IN the J2EE forum look at my mini-how to. Works for me every time.

2- It looks like you're trying to build a war file, and that has a bug
in it, it doesn't build crap. You need to use an exploded directory.

R

0
Comment actions Permalink

That bug was fixed in #1014 AFAIR

--
regards,
Alexey Kudravtsev
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Robert S. Sfeir" <robert@codepuccino.com> wrote in message news:bs5mha$d0p$1@is.intellij.net...

Glen Stampoultzis wrote:

I'm trying to get webapps going as I've been stuck with 977 for some time
now. Sadly I don't seem to be able to get them to work with the latest EAP
either.

>

I'm getting the following error during compilation:

>

Error: duplicate entry: WEB-INF/classes/blah blah/AccessRight.class

>

I've hunted all morning but I can't find out what I'm doing wrong. Anyone
able to help? For the moment I'm switching back to 977.

>

1- IN the J2EE forum look at my mini-how to. Works for me every time.

>

2- It looks like you're trying to build a war file, and that has a bug
in it, it doesn't build crap. You need to use an exploded directory.

>

R



0
Comment actions Permalink

>> That bug was fixed in #1014 AFAIR <<

.. getting a similar error in 1108 ....

0

Please sign in to leave a comment.