Intellij Idea randomly stops working


I have already posted on stackoverlow and again, a little different on stackoverflow, but no luck.

Intellij Idea randomly stops working and therby blocks  some things in my system. The system itself remains responsive, but I cannot start any programs through gnome3 (my wm) anymore.

I can switch to the console (I am on ubuntu 15.04) and from there do a

    killall -9 java

Then idea is killed, and all the program I tried to start immidatly pop up.

Now, while the system is "frozen" (in the sense I described above), I noticed that one of my cpu-cores has 100% usage. But looking into htop, no process uses any significant cpu power. The 100% cpu-usage drops, when I kill java.

I am using intellij idea for haXe, so it might be related to the intellij-haxe plugin, but I do not know.

My system:

Ubuntu 15.04 running gnome3.
java version "1.7.0_80"
Intellij Idea 14.1.4

Any other ideas of what I could try?



I ran "jstack -F " to cat a stacktrace. Interestingly, running this comments causes the block to be resolved. This is the output of jstack:

1 comment
Comment actions Permalink

Try running under Oracle JDK 1.8, see .

You can also modify to run java process via strace and see strace log in case it has something useful at the moment when it stops responding.


Please sign in to leave a comment.