YUI Compressor, endless minification loop for .js files

I added a YUI Compressor for Javascript on WS11, and made a simple javascript file, saved it, and to my horror started watching "temp.min.js" get created ... and then temp.min.min.js and temp.min.min.min.js and so on. I got all the way up to "temp.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.min.js" before I was able to kill WebStorm.

I didn't modify anything in the dialog where the watcher was set up, I left everything in its default state. I'm curious if anyone has seen this or has ideas on how to stop this from happening.

 

Thanks!

WebStorm 11.0.1

Ian

2 comments
Comment actions Permalink

.min.js files are still JavaScript files, and watcher listens to all them by default (watcher scope == 'project files', file type == 'javascript').
As a workaround I can suggest excluding minified files from watchers processing - create a new scope (Settings | Appearance & Behavior | Scopes) with minified files excluded (like file:.js&&!file:*.min.js), and choose this scope as your file watcher scope

1
Comment actions Permalink

Thank you Elena, that was spot on and helped me.

The pattern should be file:*.js&&!file:*.min.js though.

0

Please sign in to leave a comment.