Webstorm - Debugging options greyed out

Hi,

I have just installed Webstorm to try its debugging for our new nodejs project.

I installed and setup no problems, followed local debugging setup instructions http://blog.jetbrains.com/webstorm/2014/02/running-and-debugging-node-js-application/

However, all my breakpoint options on my run menu are always greyed out, even if I'm running in debug mode. How can I get the debugging working for your product?

Brett

CTO

Konvo.com

5 comments
Comment actions Permalink

what options are you talking about? Please attach a screenshot.

To create a breakpoint, you need using single click in the left gutter, to the right of line number, or Ctrl+F8 in editor.

0
Comment actions Permalink

Hi Elena,

I mean that when I pull down the Run menu, the debug options are greyed out. I also mean that when I single-click in the gutter, or am in the editor and press Ctrl+F8 nothing happens (i.e. no breakpoint appears).

I have worked with different IDE's and am confident it is some kind of configuration error, and so I also attach an image of my my greyed out Run menu and my Run/Edit configuration window.

 

Please help

Brett

0
Comment actions Permalink

Menu options are disabled because stepping in/out/etc. is only possible when the program execution is suspended because the breakpoint is hit. In your screenshot, no breakpoints are hit - thus the issue. As for setting breakpoints by clicking in the gutter/hitting Ctrl+F8 on a line, this should just work - no special configuration is needed. So I have no idea what's going on. Please record a screencast that shows up the issue.

0
Comment actions Permalink

I'm having this problem even when I hit a breakpoint.  I can see in the console and on my web page (using sockets which have stopped receiving updates) that I have hit my breakpoint, and execution is suspended.  However, all the step and run icons are grayed out in the toolbar, along with the menu items in the Run menu.  Pause Program is enabled, and the Debugger view only shows Connected to localhost:63292 with no Frames shown.  Even though execution is suspended, the UI looks like it is not.  Clicking Pause Program has no effect.

This is very frustrating and very repeatable.  I have tried restarting Webstorm, but that does not help.

My application is using Bluebird promises, as well as reacting to streaming events coming in over HTTP.  I am able to stop at more "mundane" breakpoints, but I get the feeling that the more exotic areas of execution are causing problems for the debugger.  The thing is, it's the UI that seems to be broken.  The debugger itself seems to be able to break as expected.

0
Comment actions Permalink

it's not a UI issue most likely, seems wrong line numbers are returned. Sample project that shows up the issue would be helpful

0

Please sign in to leave a comment.