Dart plugin doesn't install in CLion but works elsewhere (update)

This is the same post as https://intellij-support.jetbrains.com/hc/en-us/community/posts/205841949-Dart-plugin-doesn-t-install-in-CLion-but-works-elsewhere.

I couldn't comment to reply on my own post but I have provided a screen shot here. I was using the latest CLion 1.2.4 available at that time.

 

I've downloaded the Dart plugin 143.1566 and installed it successfully in PyCharm. https://plugins.jetbrains.com/plugin/6351 Now I am trying the CLion evaluation version and installing the same plugin gives the error message "Plugin 'Dart' is incompatible with this installation". The Dart plugin page (link above) lists CLion as a supported platform. Is this because I'm using CLion evaluation or is the Dart plugin actually not supported in CLion?

 

2 comments
Comment actions Permalink
Official comment

Your CLion build is 143.1186. According to the 'Compatible builds' column at Dart plugin page you should use Dart plugin version 143.1247.

By the way, unless you are behind a firewall, the best way to install plugins is right from the IDE: Settings | Plugins | Install JetBrains Plugin.

Comment actions Permalink

Hi Josh.

Sorry for the delay. I've successfully installed Dart plugin v143.1247 for CLion. Could you please specify how did you install it? Did you use Preferences | Plugins | Browse Repositories - choose Dart tab for install it?

0

Please sign in to leave a comment.