Python 3.5 not recognized on Ubuntu 14.04

Answered

In a project, when I go to Project Structure, under Project Settings in the Project section, when selecting python3.5 executable for the Project SDK, I get the following error:

Probably SDK installed in '/home/my_name/my_path/env/bin/python3.5' is corrupt

However it is not corrupt since I can open it without problem from a shell terminal. I only get this error with Python 3.5, older version are working fine (3.4 or 2.7).

I have the python plugin installed: Version: 5.0.2.143.121

Is it a bug? Can someone help me work around this problem?

Thanks

1 comment
Comment actions Permalink

Solved. Here's how if someone else encounters the same problem.

When launching IDEA (idea.sh), I needed to LD_LIBRARY_PATH to contain the python3.5 lib path.

0

Please sign in to leave a comment.