SSH_MSG_DISCONNECT 2 Too many authentication failures for root - HELP

When I try to test an SFTP connection or browse the Remote Host I always get an error with the message:  SSH_MSG_DISCONNECT 2  Too many authentication failures for root.  I know its to do with sending too many ssh keys to the server but how do I remove them or clear them?

6 comments
Comment actions Permalink
Official comment

Hello,

Fixing of this issue should be performed at the remote server side since it's SSH server who blocks the connection. Please check the solution at <https://superuser.com/questions/187779/too-many-authentication-failures-for-username>.

Comment actions Permalink

and, what if the remote server is not the issue?

I can connect fine with same credentials with many other soft and command line.

 

Only way i get ride of this is pointing a brand new server, and get back to the original one

0
Comment actions Permalink

Maybe there's something wrong with the password/passphrase? What OS are you on?
If it's not Windows, please try switching to the KeePass at Settings | Appearance & Behavior | System Settings | Passwords, restart PhpStorm, go to the deployment configuration and re-type (not paste!) the password and check if it accepts the credentials now.

0
Comment actions Permalink

My IP seems to get temporarily locked out of my Debian SSH server by using PyCharm SSH tunnel/Database to connect.

Connnecting to the server via command line SSH with the same credentials works fine.

Testing the connection within PyCharm gives the green "Success" response, so I save the details. However, if I then double-click on the database it fails, giving me "Too many authentication failures". I only tried to open it once, is PyCharm trying multiple times in quick succession?

As a result I then get locked out of my command-line SSH for several minutes. As you can imagine, trying this again is wasting a lot of time when I'd like to be looking at the contents of the database... So I can't use PyCharm for DB connections any more.

 

0
Comment actions Permalink

Github, what OS are you on? Is it Linux? If so, please follow my advice from the comment above and switch to using KeePass.

1
Comment actions Permalink

The KeePass solution posted by Eugene worked for me on Ubuntu 18.04.

0

Please sign in to leave a comment.