django - I can run the server but cannot debug

I recently setup my pycharm for django.

I got the server running and I can hit the site on broswer.

But I cannot get debug to work, It will not hit any of the breakpoints.

 

When I hit debug it will show the following error:


pydev debugger: process 8076 is connecting

Traceback (most recent call last):
File "C:\Program Files (x86)\JetBrains\PyCharm 5.0.3\helpers\pydev\pydevd.py", line 2407, in <module>
globals = debugger.run(setup['file'], None, None, is_module)
File "C:\Program Files (x86)\JetBrains\PyCharm 5.0.3\helpers\pydev\pydevd.py", line 1798, in run
launch(file, globals, locals) # execute the script
IOError: [Errno 2] No such file or directory: '-Wignore:RemovedInDjango19Warning'

 

Please Advise.

Thanks

6 comments
Comment actions Permalink
Official comment

There is the issue of this bug in our tracker: https://youtrack.jetbrains.com/issue/PY-9033 

Please, follow it for updates (http://intellij-support.jetbrains.com/entries/23368682). Thank you for the feedback!

Comment actions Permalink

PyCharm doesn't yet support Django 1.9. The latest PyCharm EAP has a fix for one issue related to template debugging. You could give that a try and see how it works.

0
Comment actions Permalink

Hi! Please, provide the beginning of the console output (before the line "pydev debugger: process 8076 is connecting"), when you start your debug session. Thank you!

0
Comment actions Permalink

I got it to work somehow. The issue is with one of the env variables   PYTHONWARNINGS : ignore:RemovedInDjango19Warning

After I removed that variable it works fine except I see those Django19 warnings. Any idea why this is happening?

 

@Eliz: there is nothing much above that line, see below

"C:\Program Files (x86)\JetBrains\PyCharm 5.0.3\bin\runnerw.exe" D:\User\PycharmProjects\Project1\Project_manager\env\Scripts\python.exe "C:\Program Files (x86)\JetBrains\PyCharm 5.0.3\helpers\pydev\pydevd.py" --multiproc --qt-support --client 127.0.0.1 --port 64333 --file D:/User/PycharmProjects/Project1/Project_manager/manage.py runserver 8000
pydev debugger: process 6860 is connecting

Connected to pydev debugger (build 143.1559)
pydev debugger: process 8076 is connecting

0
Comment actions Permalink

Yes, I'm interested in that line exactly. The line you provided is after removing the environment variable, yes? Could you please provide that line without removing the variable?

0
Comment actions Permalink

Nope that is with the env variable. the whole log:

 

"C:\Program Files (x86)\JetBrains\PyCharm 5.0.3\bin\runnerw.exe" D:\User\PycharmProjects\Project1\Project_manager\env\Scripts\python.exe "C:\Program Files (x86)\JetBrains\PyCharm 5.0.3\helpers\pydev\pydevd.py" --multiproc --qt-support --client 127.0.0.1 --port 51518 --file D:/User/PycharmProjects/Project1/Project_manager/manage.py runserver 8000
pydev debugger: process 7320 is connecting

Connected to pydev debugger (build 143.1559)
pydev debugger: process 1324 is connecting

Traceback (most recent call last):
File "C:\Program Files (x86)\JetBrains\PyCharm 5.0.3\helpers\pydev\pydevd.py", line 2407, in <module>
globals = debugger.run(setup['file'], None, None, is_module)
File "C:\Program Files (x86)\JetBrains\PyCharm 5.0.3\helpers\pydev\pydevd.py", line 1798, in run
launch(file, globals, locals) # execute the script
IOError: [Errno 2] No such file or directory: '-Wignore:RemovedInDjango19Warning'

Process finished with exit code 1

0

Please sign in to leave a comment.