"Invalidate Caches / Restart" not working. How to troubleshoot?

This started happening after upgrading to 1.2.4. Probably I made some error during the upgrade process. Is there any log file / config I could check?

4 comments
Comment actions Permalink

(It is the restart part which does not work. When the application is manually restarted it works fine.)

0
Comment actions Permalink

Hi Jeevaka.

Could you please specify if both of the possibilities 'Just Restart' and 'Invalidate and Restart' don't work for you? Could you also please describe why you use 'Invalidate Caches/Resart' action? If you use it for clearing CMake cache we've added a special action in CLion 1.5 EAP.

0
Comment actions Permalink

Thanks for looking into this.

Yes, both 'Just Restart' and 'Invalidate Caches/Resart' fail to restart.

Yes, the reason is to clear CMake cache. Usually after a file / directory rename I have to do this to get past linker errors. My CMake setup is a is a bit complex with multiple, sometimes nested, CMakeLists.txt files and  is manually maintained. Need to invalidate is probably caused by not listing individual source files, but using 'file(GLOB_RECURSE SOURCE_FILES *.cpp *.hpp)'.

What I wanted to find out was how the restart is done / what, if any, config is used / if there is a log file I could look at, etc.

Thanks.

0
Comment actions Permalink

Please send us your idea.log which you can find via Help | Show Log in. You can send it to clion-support at jetbrains.com.

0

Please sign in to leave a comment.