Switch indentation from spaces to tabs

When I press tab it inserts two spaces. I would prefer for it to enter a tab character instead. Here are my settings:

  • File > Settings
  • Editor > Code Style
  • Detect and use existing file idents for editing (unchecked)
  • HTML
  • Tabs and Indents
  • Scheme: Ryan
  • Use tab character (checked)
  • Smart tabs (checked)
  • Tab size: 4
  • Indent: 4
  • Continuation indent: 4
  • Keep indents on empty lines (unchecked)

 

  • File > Default Settings
  • Editor > Code Style
  • Detect and use existing file idents for editing (unchecked)
  • HTML
  • Tabs and Indents
  • Scheme: Project
  • Use tab character (checked)
  • Smart tabs (checked)
  • Tab size: 4
  • Indent: 4
  • Continuation indent: 4
  • Keep indents on empty lines (unchecked)

There are no .editorconfig files in parent folders. I have also done Edit > Convert Indents > To Tabs but the two spaces persist.

Do you know what settings I need to change for the tab character to insert a tab character instead of two spaces?

2 comments

does this issue occur in new .HTML files? If you have 'Use tab character' enabled, and you still have spaces inserted when you hit Tab in a newly created .html file, try disabling EditorConfig support in Settings >Editor > Code Style by unchecking 'Enable Editorconfig support' checkbox 

2

Lena,

Disabling EditorConfig solved my issue - thank you!

Ryan

P.S. It occurred in new and existing files.

3

Please sign in to leave a comment.