CLion Debugger - I don't see global variables while debugging...also some variables don't update properly...

Hi.  I'm trying to debug an app and having some issues keeping track of variables...

1)  Global variables are not showing up anywhere

2)  Some variables never show what the value is even though it's holding a value and works properly (if check works)

3)  Some variables show old values in the debugger even though when stepping through the code the variables have the correct values

Wondering if there is anything I can do to get the debugger to work properly?


Hi Andy.

Could you please specify which CLion version and OS you are using? Do you use bundled GDB or not? Could you send us a sample project so we can take a look at what is going on (to clion-support at


I have the same problem... I don't see the global variables.

OS X version: 10.12.3

CLion version: 2016.3.3


Sorry, I've switched to Visual Studio.  I could not get this to work at the time while it worked as expected in Visual Studio without much effort.


I use msvc toolchain with bundled LLDB and don't see global variables also



Hello all! It's not supported yet, unfortunately - Feel free to comment or upvote the issue. See if you are not familiar with YouTrack.


Anna Falevskaya IMO, this issue should be bumped. It's a quite essential feature that is opened 10 years ago and still no progress



Please sign in to leave a comment.