PyCharm Community - Patch update 5.0.3 to 5.0.4 won't apply

Env:

Kubuntu 14.04, VirtualBox

Running PyCharm as root from the command line. The update is enabled, and after clicking Download and Restart, the patch seems to be downloaded, but the IDE restarts running the same old version, and the update still enabled.

3 comments
Comment actions Permalink

I also seem to have this problem.

PyCharm: 5.0.3 (trying to update to 5.0.4), Professional

Ubuntu 14.04

It works just like Amit Geiron describes above: I click the update link which opens the updating dialogue:

 

Then it returns to the same startup screen. After three attempts, this is what I have on my command line:

$ sudo pycharm
log4j:WARN No appenders could be found for logger (io.netty.util.internal.logging.InternalLoggerFactory).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
[ 114341] WARN - pl.local.NativeFileWatcherImpl - Watcher terminated with exit code 0
log4j:WARN No appenders could be found for logger (io.netty.util.internal.logging.InternalLoggerFactory).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
[ 19969] WARN - pl.local.NativeFileWatcherImpl - Watcher terminated with exit code 0
log4j:WARN No appenders could be found for logger (io.netty.util.internal.logging.InternalLoggerFactory).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
[ 410857] WARN - pl.local.NativeFileWatcherImpl - Watcher terminated with exit code 0
log4j:WARN No appenders could be found for logger (io.netty.util.internal.logging.InternalLoggerFactory).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
0
Comment actions Permalink

Eventually, the new version was downloaded and installed via apt-get.

0
Comment actions Permalink

I see that this has been known about for a while...I've just discovered it happening with my 5.0.3 (Xubuntu 14.04).

So I'll have to download the whole thing again...

 

graham

0

Please sign in to leave a comment.