connexion with datagrip to my raspberry pi 2 (server LAMP)

Hi,

I have a problem. I just went to create a server LAMP on my raspberry pi2. I have acces to the mysql with phpmyadmin but i can't get it with Datagrip. I maybe have bad configuration ? Can you give me hrlp ?

Thank you,

Romain, a little french guy

7 comments
Comment actions Permalink

Hello Romain,

What is the Database? What error are you getting when trying to connect? Double check that connection settings (port, host, user/password) are correct. Please attach screenshots of General tab with the connection settings if issue remains.

0
Comment actions Permalink

hi,

thank you for the answers

here is my settings : http://puu.sh/n3MZQ/a3265dd216.png

0
Comment actions Permalink

Settings look correct. What is the error?

0
Comment actions Permalink

so i put the error on the screeshot here : http://puu.sh/n4bun/890b75e6a0.png

i try to conect on my php with my ip and it's work and i can connect with phpmyadmin to. I don't understant why it does not work ?

0
Comment actions Permalink

Make sure that mysql server is configured for accepting tcp socket connection (rather than named pipe, see http://unix.stackexchange.com/q/32134 ) and the server tcp socket number is the same as you are specifying in DataGrip connection settings (Port option in General tab).

0
Comment actions Permalink

I finally solve my probleme with : http://raspbian-france.fr/activer-connexion-distance-mysql/

it's in french but it has work for me. It explain howyou have to comment to allow external computer to connect on the server.

Thank you for the help,

Romain

0

Please sign in to leave a comment.