PhpStorm extremly slow

Hello,

PhpStorm needs over one minute to start. After I see the main screen i can go into settings, but it needs again about one minute until it shows any options.

I have already tried to delete all PhpStorm related folders and download it again. Also tried to use openjdk7 and openjdk8, always the same Problem. I am running Arch linux 64 Bit.

I also use WebStorm, it is working without any Problems, only PhpStorm is affected.

When i start PhpStorm via console there do not show up any errors.

I also made a Video: https://youtu.be/cbJvrljtOQk

Does anybody have an idea what i can do?

Regards,
Stefan

3 comments
Comment actions Permalink

Hi Stefan,

Could you please restart the IDE and then collect the IDE log?
Also, please attach a Perfomance Summary report from 'Help | Diagnostic | Show Perfomance Summary'.

0
Comment actions Permalink

Hello and thanks for your reply.

IDE Log: https://gist.github.com/1994rstefan/9a1df813a333992a56a3
Performance Summary Report: https://gist.github.com/1994rstefan/040118cb644e3652b4c9

I can not see any problems here - hopefully you can see something.

After some testing - after the IDE is fully loaded i can work normaly. When I open a project instead of the settings like in the video PhpStorm takes a long time to index the project (about the same time it needs to load the settings). But after that point it seems everything works without any problems.

Regards

0
Comment actions Permalink

Oh my gosh - I found the problem.

The hostname of my Computer (/etc/hostname) was not set inside my hosts file (/etc/hosts) to resolve to 127.0.0.1. After adding the hostname inside hosts file PhpStorm starts within a few seconds.

Even if WebStorm was starting a lot faster than PhpStorm it was also affected. WebStorm now starts within a few seconds, before it took about 10 to 15 seconds, i thought that this was normal.

1

Please sign in to leave a comment.