can't add org.osmdroid:osmdroid-android:5.1@aar

Answered

IJ 16 CE, no gradle (old project), I wanted to update osmdroid to new one.

But there is no jar now, only aar.

 

But i can not load library (or Global library) like before:

      org.osmdroid:osmdroid-android:5.1@aar

it tries to add and fails, saying no downloaded.

Is it even possible without gradle?

 
4 comments
Comment actions Permalink

If you are not using a Gradle project, support for Android is quite different in AS and IntelliJ IDEA. I'd recommend migrating to Gradle.

1
Comment actions Permalink

Thank you, but AS supports aar (but there is no maven lib loading feature).

Is this AS and IJ do not go toe to toe?

 

and anyway, what we have to do? how to use popular osmdroid for example? no jar.. import module? badly

0
Comment actions Permalink

Ok, clear. Thanks again.

 

Сергей, увы, грабли - нет. Я ждал год и подожду еще парочку лет. Пока что gradle очень сложна, непонятна и недружелюбна, вылетает, пишет странное, 90% времени приходится гуглить и разгребать а что же такое не работает опять. А уж расположение файлов и настроек - как линукс против винды. Так что пока нет.

 

В любом случае, обе IDE от IDEA - лучшие и образцовые.

0

Please sign in to leave a comment.