Use Option as Meta Key for OS X Terminal Does not work inside Webstorm

After setting my OS X keyboard to use "Use Option as Meta Key" in the keyboard preferences in OS X, that allows me in terminal to use combinations like Alt + b and Alt + f to move from word to word.

But once I'm inside Webstorm that doesn't work anymore, why not?

5 comments
Comment actions Permalink

may be because this is OSX Terminal preference, why should it affect other applications, including WebStorm?

0
Comment actions Permalink

well that sucks if that's the case, why would I want to have to rebind my keys when I like how it already works in Terminal and terminal is being integrated into webstorm.

0
Comment actions Permalink

see https://youtrack.jetbrains.com/issue/IDEA-113214 - seems something of this kind is planned for PHPStorm 11

0
Comment actions Permalink

I have the same problem running IntellliJ on OSX; The Meta key, which is mapped to my Mac's Option key in my Terminal Preferences (->Profiles->Keyboard, "Use Option as Meta key"), responds as the default Option key when the "embedded terminal" is running in IntelliJ. As a heavy power-user of the bash shell (which in turn has a host of Meta-related, Emacs-y commands), this has meant so far that the terminal within IntelliJ is close to worthless for me. So I for one would certainly love to hear about fixes.

0
Comment actions Permalink

Just found a more generic issue on the tracker that best describes the exact problem: https://youtrack.jetbrains.com/issue/IDEA-165184

0

Please sign in to leave a comment.