Please help me configure MS SQL Access

I connect to an MSSQL database via vpn.  Using Navicat I can connect just fine with the following settings:

 

Hostname: 192.168.2.6 (the address of the sql box on the remote server)

Authentication: SQL  Server Authentication

Username & Password.

I don't have to specify a given port.

However, I can't connect via PHPStorm.  Any ideas?

 

13 comments
Comment actions Permalink

What messages do you have in a View > Tool Windows > Event log > Database tab? Are you able to connect to MSSQL server from  a PhpStorm box via cmd using sqlcmd (cmd > sqlcmd -S 192.168.2.6\<instance> -U <username> -P <password>)? See technet for reference.

0
Comment actions Permalink

Here is the error message:

QL Server (Microsoft) - Andover@192.168.2.6 (14s)
Connection to SQL Server (Microsoft) - Andover@192.168.2.6 failed
This driver is not configured for integrated authentication

I don't have the sqlcmd utility on this machine (win7 connecting by vpn to windows server).

 

As I mentioned, I can connect via navicat.

0
Comment actions Permalink

Hi there,

Please show screenshots of your DB connection settings (General tab + any changes that you have made on Advanced tab)

0
Comment actions Permalink

Thanks for your help.

0
Comment actions Permalink

This looks different to what you have said earlier.

On your screenshot you are connecting to localhost instead of 192.168.2.6

I believe you should have:

  • Host = 192.168.2.6
  • Instance = empty

Also -- in Navicat -- do you do any other settings except basic host/db name/user/password ?

1
Comment actions Permalink

I've swapped them...same error.  Here are the settings in navicat...there are no advanced settings.

0
Comment actions Permalink

Can you please show the screenshot from PhpStorm with the new settings?

Please also try ticking the "Save password" check box

0
Comment actions Permalink

And what -- it still produces the same error (as in original message)?

If so then I do not know what else it may be. Maybe your PC misses some other files (I do have local SSMS installed + SQL Server drivers (both native & ODBC) -- maybe it makes the difference here).

0
Comment actions Permalink

If you click "Test connection" - would it fail? What do you have on Advanced tab in Navicat?

0
Comment actions Permalink

BTW, I've tried w and w/o a port being specified (as navicat does not specify a port)

0
Comment actions Permalink

ok guys...thanks for your help.  I was just evaluating the program.  I'll just stick to my old tools.  Thanks for your help!

 

0
Comment actions Permalink

1433 is the default port for client connections.

1434 is for DAC, which needs to be enabled first on the actual server.

Maybe it's your local firewall issue (firewall/internet security that can block access on per application level)?

0

Please sign in to leave a comment.