OSX, separate Space, floating Run window on the second screen, clicking it moves to the first screen.

Answered

IntelliJ IDEA 15.0.3

JRE: 1.8.0_40

JVM: OpenJDK 64-Bit Server VM

OS X 10.11.3

 

Steps:

1. On OS X, connect two monitors (M0 and M1). 

2. Enable Separate Spaces in Preferences.

3. Place IntelliJ on M0.

4. Set Run Window to Floating Mode, and place it on M1.

5. Focus IntelliJ by clicking it.

6. Focus the Run Window by clicking it.

 

Result:

The Run Window teleports from M1 to M0. For example, if it was at (10,10) on M1, it now is at (10,10) on M0.

 

Workaround:

Disable Separate Space in OSX preferences.

2 comments
Comment actions Permalink
Official comment

It's a known issue, please see https://youtrack.jetbrains.com/issue/IDEA-116096 and linked bugs.

Comment actions Permalink

Thanks for the link. I had searched this forum before posting this but did not find similar post.

Anyways, it is quite surprising that this issue has been there for over two years and still has no plan for fix. Probably there is little hope at this point...

0

Please sign in to leave a comment.