Copy script result with column names

Answered

Hi,

When running a script, I am unable to copy the contents as plain text, and include the column names. I have looked for a setting for this, but I can't seem to find it. In general it's better to include headings by default when copying, as it's usually easier to delete a single row at the top, than to re-type all of the column headings, or go through another method to export them.

I have read a previous response to this topic, however I cannot find the options or menus alluded to there: https://intellij-support.jetbrains.com/hc/en-us/community/posts/206634265-Copy-to-Clipboard-include-column-names

Thanks!

5 comments
Comment actions Permalink

In the Database Console results tab there is Configure CVS Formats... action available:

 

where you can enable First row is header option to include header to be displayed in exported results.

Does it help?

-1
Comment actions Permalink

What I was interested in was copy and pasting from the results panel a subset of columns/rows with the header included, and did not realize that I could select TSV and set that up to export how I needed.

 

Typically I am doing this to paste into Excel.

 

Thanks for pointing out how to do it, it works well now. Maybe the settings should be made more obvious that these configurations items affect the copy function too.

 

1
Comment actions Permalink

I use Toad or Sql Server management studio, both programs allow you to export headers. In fact, this is the only database tool I know of that does not. :-(   - I'm really trying to like this.

0
Comment actions Permalink

Thanks for the information, it's very useful.

SQL Complete will be also helpful in this case. Have you tried it? 

0

Please sign in to leave a comment.