Remote SSH Tool Keeps Prompting me for Credentials

I have configured a "Remote SSH External Tool" Under the connection i have told it to use "Deployment Server" I dont have SSH as an option for a deployment server, so i configured sftp. Every time I run the external tool, it just gives me the option to "enter credentials" and while what i enter does run the command, there is no option to save the credentials.

The documentation leads me to believe that there may be an "SSH" deployment option missing, or something like that. I also tried configuring a remote ruby sdk with SSH credentials, nothing changed, the server did not show up in the list when running the external tool.

 

Is there a plugin i need, other than the "remote Host Access" plugin, which i have.

1 comment
Comment actions Permalink

Hello, Tim,

sorry for the delay. Could you please check how it goes in the last RubyMine EAP for 2016.2, I didn't manage to reproduce your issue there. If it persists please attach screenshots of Tools | Remote SSH External Tools and Build, Execution, Deployment | Deployment 

0

Please sign in to leave a comment.