Database tool autenication

Answered

Has something changed in latest 15.0.4 release with the database|datasource configuration?

I have dbs configured but chosen not to store the passwords with 'master password protection'. In earlier builds when I attempted to access the database for first time in a session IntelliJ would pop up a window asking for the DB username and password. After entering the password it would work fine.

But now instead of prompting for a password I get a failure events:

2:48:12 PM [08001] Could not create connection to database server. Attempted reconnect 3 times. Giving up.
[28000][1045] Access denied for user 'dbuser'@'localhost' (using password: NO)

 

Seems it thinks no password is required? this isn't true and I cannot find a way to force the db auth prompt? i.e. switch to using password YES

 

Using IDEA 15.0.4 on CentOS 6 - only thing that changed was my IntelliJ version (patched from 15.0.3).

 

6 comments
Comment actions Permalink

Hello Richard,

I can not reproduce the problem. I'm always prompted with password. Could you please describe the steps to reproduce this issue? What database are you connecting to? What options do you have in File | Settings | Appearance & Behavior | System Settings | Passwords and in Data Source dialog?

Please also try IDEA 16 preview build from https://confluence.jetbrains.com/display/IDEADEV/IDEA+16+EAP .

0
Comment actions Permalink

Its just MySQL 5.1 local to the same CentOS VM.

The system settings for password are set to: save on disk with master password protection (though I don't use it, didn't know this setting page existed).

When I first start up the IDE in the datasource properties the password field appears as <hidden> which I guess is empty.While the save on disk with master password protection checkbox is unchecked. Everything else looks pretty default, there is a username stored.

Keep seeing warnings about password required NO where I used to get popup password prompts whenever I click the tables in the database window. I have to manually reopen the datasource properties and enter a password there that'll be good for the IDE session. Happens everytime I try to access the tables after restarting IDEA. Also happens if I click Test button on datasource properties if I don't change the <hidden> password manually.

Only thing I changed was the IDEA update, has been working fine on same project for years up until now.

0
Comment actions Permalink

Spent the last 20mins trying every combination of password setting, restarting the IDE no luck at all with MySQL. Even tried creating a new datasource for the DB and still no luck.

But when I tried an Oracle connection I did get a user/password prompt, but it looks like it already tried to login with a 'null' password before it decided to show the prompt? I'm guessing MySQL is handling this null attempt differently in 15.0.4 and this is why no prompt appears (assumes no password required so tries that 3 times and bails).

MySQL always fails, suspect other DB vendors driver might also.

0
Comment actions Permalink

Thank you Richard for information. I've created an issue in YouTrack: https://youtrack.jetbrains.com/issue/DBE-2438 please follow for updates. Would you please attach idea.log to YouTrack issue after reproducing the problem. Thank you!

0
Comment actions Permalink

you need select this item

0
Comment actions Permalink
sudo apt-get update
sudo apt-get install gnome-keyring
0

Please sign in to leave a comment.