Cannot Edit any Files


Good Morning

I installed IntelliJ IDEA 15 on OSX these days (including studing license) but I seems that I cannot edit any files. When I hit the J or K keys, I can navigate up and down. I'll try to run a Play 2 app, and running is not even a problem. Starts up without any problems...

The read-only mode isnt toggled in IntelliJ and Files are all editable with other editors like VI, Atom


Any hints on this issue?

Comment actions Permalink

Solution found: Removed Vim Emulator Mode *facepalm*

Comment actions Permalink

WOW!  I was having the same issue and removing the emulator worked. Why is that? Forgive my ignorance. I am a vim user on *nix systems. I understand the plug-in is supposed to facilitate JAVA project editing. And I was able to use vim commands in the terminal window. Does the plug-in supersede the functionality in the editor window as a feature or a bug? And whose 'bug' is it - JetBrains or the developer of the plug-in? 

System Specs

Windows 10 | IntelliJ IDEA 2016.2
Build #IU-162.1121.32, built on July 9, 2016
JRE: 1.8.0_92-b14 amd64
JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation


Comment actions Permalink

Thanks Philippe.

Had the same problem on Mac OS X 10.11.5 with IntelliJ Ultimate 2016.2.


Go to Main Menu > Preferences > Search for "Vim Emulator Mode" > Remove/Delete > Restart Intellij 

Comment actions Permalink

Thanks Philippe!!!


I had this issue on my MAC 10.12.6 with IntelliJ Community Edition 2017.2.


Go to Tools Menu > Click on VIM Emulator to disable it. I was able to edit the file again w/o any restart.

Comment actions Permalink

I had the same issue on macOS Sierra 10.12.6 with webstrom 2018.1. Unchecked the VIM Emulator in Tools menu without restart solved the issue

Thank you guys for the solution!!!

Comment actions Permalink

Lekker! Same here - Remove VIM Emulator 


Please sign in to leave a comment.