grails command results in Exception: java.lang.StackOverflowError thrown from the UncaughtExceptionHandler in thread "main"

Answered

Hi,

since some EAP version I can't execute grails commands from inside intellij. Console shows: Exception: java.lang.StackOverflowError thrown from the UncaughtExceptionHandler in thread "main"

Executing the command from cmd.exe works fine.

 

Win7 64bit, IntelliJ IDEA 2016.1 145.256.33

Example of a command:

"C:\Program Files\Java\jdk1.7.0_60\bin\java" -Dgrails.home=D:\grails\grails-2.5.3 "-Dtools.jar=C:\Program Files\Java\jdk1.7.0_60\lib\tools.jar" -Dgroovy.starter.conf=D:\grails\grails-2.5.3/conf/groovy-starter.conf -Xmx768M -Xms768M -XX:MaxPermSize=256m -XX:PermSize=256m -Djline.WindowsTerminal.directConsole=false -Dbase.dir=D:\projekte\wiso\wex-adm -Dfile.encoding=UTF-8 -classpath D:\grails\grails-2.5.3\lib\org.codehaus.groovy\groovy-all\jars\groovy-all-2.4.4.jar;D:\grails\grails-2.5.3\dist\grails-bootstrap-2.5.3.jar org.codehaus.groovy.grails.cli.support.GrailsStarter --main org.codehaus.groovy.grails.cli.GrailsScriptRunner --conf D:\grails\grails-2.5.3/conf/groovy-starter.conf "list-plugin-updates -plain-output"

How can I solve the problem?

 

Thanks, Michael

6 comments

Does it still work in 15.0.4 release with the same project and Java/Grails versions?

0

Yes. I updated 15.0.2 to 15.0.4 and grails commands work fine.

0

I've reported a bug at https://youtrack.jetbrains.com/issue/IDEA-152910, please follow it for updates. It would help if you attach the full error message and idea.log to the issue (https://intellij-support.jetbrains.com/hc/articles/207241085).

0

Thanks, I'll attachement the Infos on monday, when I'm back in office.

0

No need for this, I've already located and fixed the issue. 

0

Please sign in to leave a comment.