WebStorm 2016.1 seems to have lost React recognition

I upgraded to Webstorm 2016.1 (WebStorm-145.258.3) this morning, and much of the nice React support that was present in the previous version I was using (WebStorm-143.382.36) seems to have been lost. For example, this.state and this.props are both unrecognized in the latest upgrade, as shown below.

You can see the previous version running on the left, and the updated version running on the right. They're both using the same set of preferences, but the updated version is clearly missing some recognition of React.

Was something perhaps missed when importing my preferences, or did something get disabled?

6 comments
Comment actions Permalink

what language do you use - ES6, TypeScript? Can you provide a sample project that shows up the issue?

0
Comment actions Permalink

I have exactly the same issue

^ test.jsx with JSX Harmony

Worked fine until 2016.1 :)

0
Comment actions Permalink

It workes if I make a new project, it's interesting thought that if I `cmd + click`  props on this.props, it leads me to `/node_modules/babel-runtime/helpers/jsx.js`

0
Comment actions Permalink

Fixed it, apparently I had `node_modules` in the Project's Libraries :(

0
Comment actions Permalink

I can't edit my comments :( 

 

0
Comment actions Permalink

Welp, Radu, you solved it for me. I had included node_modules in my projects libraries as well. I'm not sure when or why I put it in there, but it didn't cause any problems until I upgraded. Either way, removing it fixes the problem!

Thanks!

0

Please sign in to leave a comment.