PyCharm 2016: JRE undefined symbol: FT_Library_SetLcdFilter

Just downloaded PyCharm 2016.1 and get the following warning/error when running:

> .../pycharm-2016.1/bin/pycharm.sh
OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=350m; support was removed in 8.0
.../pycharm-2016.1/bin/../jre/jre/bin/java: symbol lookup error: .../pycharm-2016.1/jre/jre/lib/amd64/libfontmanager.so: undefined symbol: FT_Library_SetLcdFilter

System Info:

> uname -srvmpio
Linux 2.6.18-407.el5 #1 SMP Fri Oct 16 12:04:40 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux
> cat /etc/redhat-release
Red Hat Enterprise Linux Client release 5.11 (Tikanga)

Any ideas on a solution? PyCharm 5.0.4 runs fine.

6 comments
Comment actions Permalink

Same here

./pycharm.sh
OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=350m; support was removed in 8.0
Apr 01, 2016 2:00:20 PM java.util.prefs.FileSystemPreferences$6 run
WARNING: Prefs file removed in background /users/is/jredies/.java/.userPrefs/prefs.xml
./../jre/jre/bin/java: symbol lookup error: /users/is/jredies/pycharm-2016.1/jre/jre/lib/amd64/libfontmanager.so: undefined symbol: FT_Library_SetLcdFilter

cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.5 (Tikanga)

uname -srvmpio
Linux 2.6.18-308.el5 #1 SMP Fri Jan 27 17:17:51 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

 

0
Comment actions Permalink

Same.  Previous version is working.

 

~ $ cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.6 (Tikanga)

~ $ uname -srvmpio
Linux 2.6.18-238.el5 #1 SMP Sun Dec 19 14:22:44 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

0
Comment actions Permalink

It's looks like a known issue https://youtrack.jetbrains.com/issue/IDEA-151619 caused by our bundled JDK. Try to start new PyCharm 2016.1.1. Does the update help? If no try to start PyCharm under another JDK: https://intellij-support.jetbrains.com/hc/en-us/articles/206544879.

1
Comment actions Permalink

Thanks for the links Anna, using my own JDK worked, 2016.1.1 on it's own did not (same error).

Steps to fix:

  • Check your Java version:
    > java -version
    Should be 1.8 or greater
  • Find out where java is located (use whichever one works):
    > command -v java
    > which java
    Your JDK path (PATH) is that path minus '/bin/java'
  • Make sure this works:
    > PYCHARM_JDK="<PATH>" ./pycharm-2016.1.1/bin/pycharm.sh
    for me this was:
    > PYCHARM_JDK="/usr/local" ~/pycharm-2016.1.1/bin/pycharm.sh
  • You can add that variable to your startup file, or EXPORT it in your .bashrc/.profile, etc.

Also, 2016 uses a different config store, so export your settings before switching over.

0
Comment actions Permalink

Thank you Anna and Matthew! 

Same experience as Matthew - 2016.1.1 does not work, same error.

Setting it up to use my own JDK did.

--tara

0
Comment actions Permalink

Minor note, if you are trying to get this working using a launcher button (on a linux desktop, for instance)--as they don't normally run in a full shell--create a new script as below, chmod +x it, and launch it instead of pycharm:

#!/bin/bash
PYCHARM_JDK="<PATH-TO_JDK>" <PATH-TO-PYCHARM>/bin/pycharm.sh;

0

Please sign in to leave a comment.