How to disable 3 x double quote expansion to 6 quotes

Whenever I type 3 double quotes in sequence to start a comment block. Pycharm would expand it to 6 x double quotes.

How could I turn this off in options?

Thanks

 

9 comments
Official comment

Chris Raltson, I've filed the issue for this case in  the YouTrack.

Johnathan Z, if you mean the problem with generating doc strings after typing """, then it's fixed in 2016.1.1. If it's not the problem you're talking about, please provide some code samples when autocompletion isn't working as you like.

 

In Python, 3 double quotes is the start of a multi-line string, not a comment. You can turn off "pair quotes" for all kinds of quotes using Preferences -> General -> Smart Keys and de-select "Insert pair quote".

I doubt, though, that this is what you want.

0
This is definitely a bug in 2016.1.

If I type the following:

"docstring"

Then prefix it with one ", it automatically expands to:

"""docstring"

So I add a " to the end of the string and get:

"""docstring""

Then a type a third " on the end to match the beginning and it expands to:

"""docstring""""""

Same behavior whether it's a single or multiline
2

I still want the "pair quotes" behaviour so I automatically get matching quotes for strings. But I don't want PyCharm to auto expand 3 double quotes into 6 when I do multi-line comments

 

0

I'm having the same exact problem with version 2016.1.1

I would like to have the pair quotes behavior while being able to insert 3 strings, but pycharm keep going form 3 quotes to 6 quotes automatically.

I have the community version in my other computer and I don't have that problem. It seems like the professional version is the one with the issue.

 

0

Carlos Rodriguez, if it's not the problem mention by Chris Ralston, please provide the code samples when you want pair quotes behavior.

0

Hi Valentina. I upgraded to 2016.1.2. Problem still persists. Issue is prevalent everywhere, not under specific instance of code. 

Video with behaviour: https://sendvid.com/awyuuhbs 

1

 Johnathan Z, thanks for the screencast. Actually, it's a feature implemented to obtain consistency in "Insert pair quote" option behavior. Now we have only one way to disable it, as was mentioned by Paul Everitt. If you want a separate option for triple quotes, you could create a feature request in our tracker https://youtrack.jetbrains.com/issues/PY and vote for it, so if there will be a lot of votes, we will think about adding such option.

0

i think Paul Everitt meant.

settings->editor->general->smartKeys

At least it is accessed that way in PyCharm 2016.1.2.

Love and peace,

Joe

0

Please sign in to leave a comment.