Cannot run RSpec from RubyMine 8.0.3 despite the gem being in the project and runnable from the terminal

Whenever I right click inside a _spec file and select 'Run spec...', I get the following error:

"RSpec support is disabled because 'rspec-rails' gem or RSpec Rails plugin are missing. Install and activate gem at first".

The gem is included in my Gemfile as follows:

group :development, :test do
# Call 'byebug' anywhere in the code to stop execution and get a debugger console
gem 'byebug'
gem 'rspec-rails', '~> 3.0'
gem 'capybara'
end

I can run the tests just fine in the terminal using 

bundle exec rspec

The Capybara test runs just fine and returns the errors as expected.

I also searched for an RSpec Rails plugin but I found nothing. I tried both Google and the Plugins section in the Preferences, using the Browser Repositories button and Install JetBrains plugin.

I'm at a loss as to why this is failing to execute. If I right click my "spec" folder and select Run..., I simply get a "Test framework quit unexpectedly" error, which I suspect is because it's trying to use MiniTest, which isn't installed, instead of RSpec.

4 comments

I'm having this exact same issue.  It was working correctly in my projects when I first downloaded the application in January, but I think some patch has broken the feature.

It looks like there is something wrong with the Plugin.  Either that, or I've messed up my environment in some way.

Would love to get an answer from JetBrains though.

0

I believe this issue may be related to other issues I'm seeing in the bug queue.  Looks like RubyMine doesn't play well with the newer versions of Ruby Gems.  The fact that it can't see the Rails gem, would be the same issue we're having here.  There are quite a few tickets regarding this issue.  It's unfortunate that it hasn't been solved yet.

https://youtrack.jetbrains.com/issue/RUBY-17808

 

0

Well that's terrible. It's the only thing stopping me from going ahead with the purchase. Hopefully it will be fixed soon.

0

This appears to have been fixed in 2016.1

I am now able to run my specs.

Since I have the subscription, it just required downloading the new version and installing it.  When asked to register, I just put in my Jetbrains account info and all was good.

HTH

0

Please sign in to leave a comment.