Debugger doesn't stop at breakpoint.

I have a problem that AppCode's debugger doesn't pause at breakpoint.

Interestingly, it works for some (most of them) breakpoints. But for some it doesn't. I am 100% sure that the code, where the brakpoint is, DOES get executed.

On Xcode, debugger stops at same breakpoint line.

Do you have any advice or how can I help solve this by providing you more data?
My AppCode version is 3.0.5.


Hi Marko,

Do you have a sample project reproducing the problem. If so, could you send it to our support e-mail (


Was there a solution to this issue?

I have the same problem with the EAP 3.3  143.380.24 and the regular AppCode 3.2.

Debugging works with XCode 7.1(71B91b). In fact I've had this problem for a while and have just been using XCode to debug, but now I want to resolve this issue.

I assume it must be a setting somewhere that I've missed but I've tried to do things that others with similar problems have ( but with no success.


Hi Victor.

Could you please specify which language do you use in your project (Swift, Objective-C or mixed)?
Also please enable debug logging by entering

into Help | Configure Debug Log Settings, restart the IDE, reporduce the problem and send us idea.log (Help | Show Log in Finder). Do not forget to disable debug logging.

Also could you please send us a sample project so we can take a look at what is going on? You can send it to appcode-support at

I have the exact same issue since upgrading xcode and appcode. Debugger worked find before but does not anymore. I am using Objective-C and sent the log as requested


I'm using AppCode 3.3 and have same problem: AppCode doesn't stop at breakpoint. log & sample project are sent to appcode-support.


To Chad and Phu and The Countless Other Devs that will come across this problem and find this post,

I found a solution to my problem, that may help with your problems! BTW I'm using Objective C.

1) Copy/Paste this code snippet into the location described by Anna (see above) 


3) Remove all breakpoints then restart AppCode.

4) Once your app has been loaded into AppCode, place a new breakpoint and then start debugging.

5) If your breakpoint is not hit then stop AppCode and go to the Help menu and locate Show log in Finder (same as Anna's description).

6) Open the log using a text editor like TextWrangler and do a search for the last entry of add_breakpoint .

7) Check to see if the output encodes any non English characters, in my case é !
Encoded -

But should of been -

So I renamed the directory and had to do as the answer to the following post described here: 

If you're lucky, then run and build should be successful. If not, do these additional steps:

1) Select the project file in Xcode, then select your app under Targets.

2) Update the Prefix Header path to reflect your new directory changes (Under Build Settings | Apple LLVM 7.0 - Language).

3) Do the same for the Info.Plist File ( Build Settings | Packaging).

I think that should be it, if not, keep searching your project for your old directory name in the Find Text Containing tool in the File Explorer area (3 icons from the left, a magnifying glass icon).

Once you get a successful build, head over to AppCode, set a breakpoint and hopefully it will now work. The breakpoints not being it appears to be related to the path encoding not being read correctly by the debugger!

I hope this helps someone as I've wasted a lot of time on this ;-)



Hi Victor, I tried your solution but doesn't help.

Actually I think this problem relates to these reported issues, in my case it is because my project path contains symbolic link. Open it from a real path (without symbolic link) make Debug stop at breakpoints.



I had the same problem. We renamed a folder in project from uppercase to camelcase (e.g. FILEBUS to Filebus). Everything worked well and was shown correctly, but in the .xcodeproj/project.pbxproj file there was still an entry "path = FILEBUS". So all files under this folder didn't halt on breakpoints. After changing the entry in proj file to the correct spelling, everything is working again.

Maybe this helps other people having the same problem...


I had this problem.

I had created a new project and the debugger would not work with the files in the new project. The project was named "DS&A" and the file that would not debug properly was "DS&A1". Debugging continued to worked properly in my other 2 projects.

I deleted the project and files with the "&" character and created a new project named "DSA" with the file "". Now debugging works fine.


Please sign in to leave a comment.