Unable to build the app, any advice?

I'm trying to build an iOS project with Appcode, but seems that something doesn't work in the proper way.
The project is an iOS7 + Apple watch OS1 project and all the dependencies are managed with cocoapods.

When I buil the project (aka the main target) with xcode everything is fine, but when I do the same with Appcode I receive this error message:

/Users/{username}/Library/Caches/AppCode33/DerivedData/{..appname..}-74ed8cd7/Build/Products/Debug-iphonesimulator/WatchKit App.app/fontello.ttf

 Note:    cd /Users/{...project path...}
 Note:    export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"
 Note:    export XCODE_DEVELOPER_USR_PATH=/Applications/Xcode.app/Contents/Developer/usr/bin/..
    Note:    /Applications/Xcode.app/Contents/Developer/usr/bin/ibtool --errors --warnings --notices --target-device watch --module {...app name}_WatchKit_Extension --minimum-deployment-target 8.2 --output-format human-readable-text --link /Users/icalo/Library/Caches/AppCode33/DerivedData/eBay\ Kleinanzeigen-74ed8cd7/Build/Products/Debug-iphonesimulator/WatchKit\ App.app /Users/icalo/Library/Caches/AppCode33/DerivedData/{.... app name ....}74ed8cd7/Build/Intermediates/{.... app name ....}.build/Debug-iphonesimulator/WatchKit\ App.build/Base.lproj/Interface.storyboardc

    /Users/{username}/Library/Caches/AppCode33/DerivedData/{... app name ...}n-74ed8cd7/Build/Products/Debug-iphonesimulator/WatchKit Extension.appex/WatchKit Extension
    Note:ld: library not found for -lPods-WatchKit Extension-AFNetworking


Hi Ignazio.

Could you please specify do you still have the problem? If yes, could you please enable extension logging by entering


into Help | Configure Debug Log Settings, restart the IDE, reproduce the problem and send us idea.log (Help | Show Log in Finder). Do not forget to disable logging after that.


problem solved, thanks you so much.


Hi Ignazio, I've got the same problem.
Can you explain how are you solved it?


I'm afraid to admint that was a stupid problem. I was trying to build an xcode project that belongs to a workspace (cocoapos).


We are in two.
I'm opening a reference in "recent files" that I believe be workspace of project.
By reopening workspace through file->open... I solve the problem.

Thanks for suggestion


Please sign in to leave a comment.