Problem with importing '__builtin__' in Python plugin 2.2

Python plugin 2.2 have problem with '__builtin__' module. IDEA suggests explict import for it but it should be used implictly.

The problem is already described and fixed in PY-249. However there is no public build with that fix avaliable yet. And the bug really hurts a lot :-(

Is there any hope to see build with this fix soon?

5 comments

Hello Alexey,

Yes, we plan to publish an updated build today.

Python plugin 2.2 have problem with '__builtin__' module. IDEA

suggests explict import for it but it should be used implictly.

The problem is already described and fixed in

http://youtrack.jetbrains.net/issue/PY-249. However there is no public

build with that fix avaliable yet. And the bug really hurts a lot

Is there any hope to see build with this fix soon?

--

Dmitry Jemerov

Development Lead

JetBrains, Inc.

http://www.jetbrains.com/

"Develop with Pleasure!"

0

Seems like the problem still persists in Python plugin 2.2.1 :-(

0

Hello Alexey,

Could you please try deleting and recreating the Python SDK?

Seems like the problem still persists in Python plugin 2.2.1

--

Dmitry Jemerov

Development Lead

JetBrains, Inc.

http://www.jetbrains.com/

"Develop with Pleasure!"

0

Oh, this time it's worked perfectly. The problem is solved. Thanks!

However the solution is not very obvious for average user :-(

Could you please try deleting and recreating the Python SDK?

0

Please sign in to leave a comment.