Unable to install QuickDialog via CocoaPods in AppCode

In AppCode, via CocoaPods, I am trying to install the pod QuickDialog. In the Podfile, I have:
pod 'QuickDialog', '~1.0'
When I go to install, I get an error saying Unknown pod name
The Message window shows:
/usr/bin/ruby /Applications/AppCode.app/Contents/bin/pod install --no-ansi
Updating local specs repositories
Failed with exit code: -1

What do I need to do?

5 comments
Comment actions Permalink

Hi Al.

Please check thet you are using pod for iOS platform. See my example of pod file:

platform :ios, '8.4' 
pod 'QuickDialog', '~>1.0'


Does that help?

0
Comment actions Permalink

Hi Anna,
Thanks for the reply. Adding that line gives the same result.

0
Comment actions Permalink

Al,

Could you please share the whole pod file? Also please specify which AppCode version are you using.

0
Comment actions Permalink

That is the entire pod file.
AppCode 3.1.7
Build #OC-139.1402 build on June 10, 2015

0
Comment actions Permalink

I found a solution. I had to go to a terminal and go to the project directory, then type:
$pod init
Then create a Podfile like so:
platform :ios, '8.0'

target 'MyProjectName' do
pod 'QuickDialog'
end
Then from the command line:
$pod install

When I did the 'pod install' command, , I got this error:
pod:command not found,
So I did a 'sudo gem install cocoapods'. This worked. There is some discussion of doing a chown on the directory instead.

When you get to where it says "Updating local specs repositories", this takes a long time (25 minutes in my case)
and there is no progress indicator.

0

Please sign in to leave a comment.