Zero Simulators To Run or Debug

Hi,

I just updated my Xcode version from 6.1.1 to 6.3.2 and also before that updated to OS X from Mavericks to Yosemite
AppCode now removed all the simulators that I have on the machine.
The simulators show up fine in Xcode, but Appcode only shows 'iOS Device'


Screen Shot 2015-06-19 at 12.05.15 pm.png

Screen Shot 2015-06-19 at 12.05.43 pm.png


I have tried
1. Restart the machine
2. Invalidate all caches on AppCode
3. Completely uninstall AppCode removing all ~/Library/Cache files and any appcode files i can find with the locate CLI. Reinstall appcode from scratch.
The problem is still there.

Has any one encountered this issue before?
I can't work with AppCode anymore, I reverted back to Xcode for the meantime.

Can you please help?
Greatly appreciated


Thanks

5 comments
Comment actions Permalink

Hi Hisham.

Could you please specify which AppCode version do you use?
Also please attach idea.log file (Help | Show log in finder) after the problem will happen again.

0
Comment actions Permalink

Hi,

I am using the latest AppCode: v3.1.7

Please find attached the idea.log file

Thanks for helping



Attachment(s):
idea.log.zip
0
Comment actions Permalink

Anyone has any idea?

Many thanks

0
Comment actions Permalink

Hi Hisham.

We believe that it may be two causes of the problem:

1. there are some problems in the project.
Please try to create new ios project. Would simulators work correctly?

2. there are some problems with simulators.
Please try to create new user for your machine, launch Xcode to create and initialize simulators, launch AppCode after that.
Does that work?

0
Comment actions Permalink

Hi Anna,

I have tried your suggestions. New projects definitely works fine. I haven't yet tried to create a new user to test the second scenario.
I also tried deleting the .idea project directory, not luck.
However, some projects started showing the simulators again, which is great. I can't put my finger on what is really fixing them, if I do, I will post an update

Thanks again.

0

Please sign in to leave a comment.