AppCode doesnt allow VIM based navigation in Read-Only files

When read-only files are open in AppCode and the Vim Emulator is activated, I got an annoying popup at every keyboard navigation keystroke asking me whether I want to clear the Read-Only status of the file.

No, I don't want to clear the Read-Only status of the file, and in fact I'm only navigating within the file and not attempting to edit it. Using the arrow keys instead of the VIM navigation keys does not cause this issue. Is this a bug or someone know how to solve this?

Attaching a screenshot of the issue. Also note that pressing "OK" after selecting "Do now not show this dialogue" doesn't do anything. The popup just remains there.

screen_shot 2015-06-24 at 9.25.44 AM.png

5 comments
Comment actions Permalink

Hi Idris.

Could you please specify what commands did you try more detailed?
I've tried to reproduce the issue with some navigation commands such as k, j, l, h, o and AppCode correctly works for me.

Also please attach a screenshot with 'About AppCode' tab and specify which IdeaVim version do you use (you can check it via Preferences | Plugins | IdeaVim tab).

0
Comment actions Permalink

Hi Anna,

In response to your questions I tried more keys, and it turns out that any letter or number key causes the problem. Perhaps the issue is that IDEAVim is not activated on these read-only files?

I'm attaching screenshots related to the AppCode and IDEAVim versions.

Thanks for your attempts to fix this!

screen_shot 2015-06-25 at 11.00.22 AM.pngscreen_shot 2015-06-25 at 11.00.47 AM.png

0
Comment actions Permalink

Looks like the issue is related to this: https://youtrack.jetbrains.com/issue/VIM-970

Any workarounds?

0
Comment actions Permalink

Hi Idris.

Yes, you are right, it relates.
Sorry, but there isn't a workaround yet.
Feel free to comment this issue and upvote.

0
Comment actions Permalink

What version of AppCode and IdeaVIM are you using so that you don't have the problem?

0

Please sign in to leave a comment.