Problem with external tools

Hi,

This might be related to the question I've asked in http://www.jetbrains.net/devnet/thread/288712?tstart=0

I'm having trouble using external tools in Pycharm (I'm using a Mac, by the way).

I've set up an external tool with the following info:

  • Name: Open in Path Finder
  • Program: /usr/bin/open
  • Parameters: -a '/Applications/Path Finder.app' '$FileDir$'

When I run it, the console output is:

/usr/bin/open -a '/Applications/Path Finder.app' '/Users/julien/Documents/djangosite/content'

The files /Applications/PY-96.243.app/bin/Finder.app' and /Applications/PY-96.243.app/bin/'/Users/julien/Documents/djangosite/content' do not exist.

Process finished with exit code 1

... and nothing happens. It works perfectly when I run the same thing directly from the terminal (i.e. it opens the given directory in Path Finder).

Another tool I've made has the following info:

  • Name: Copy Path
  • Program: /bin/echo
  • Parameters: '$FileDir$' | pbcopy

The output is:

/bin/echo '/Users/julien/Documents/Development/djangosite/content' | pbcopy

'/Users/julien/Documents/Development/content' | pbcopy

Process finished with exit code 0

... and again nothing happens. It works fine when the same thing is run from the terminal (i.e. it copies the path to the clipboard).

The third tool I've made does not work either:

  • Name: Launch Terminal
  • Program: /usr/bin/osascript
  • Parameters: -e 'tell application "Terminal" to do script "cd $FileDir$"'

The output is:

/usr/bin/osascript -e 'tell application Terminal to do script cd /Users/julien/Documents/djangosite/content'

2010-05-31 18:40:08.290 osascript[72990:903] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:

/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper

osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.

0:1: syntax error: A unknown token can’t go here. (-2740)

Process finished with exit code 1

Note that the double quotes (") are always stripped out when running external tools...

Could you please let me know if I'm doing anything wrong? I've spent several hours trying to make this work and now I'm really at loss.

Many thanks!

Regards,

Julien

Please sign in to leave a comment.