Highlight TODO / FIXME / etc comments

Hi,

I notice that pycharm highlights:

# TODO: something

comments automagically in bright blue which is very handy. Is this a config options somewhere? As I would like it also to be able to highlight # FIXME: # BUG: etc comments.

BTW, I love pycharm :-) its the first Python IDE I've stuck with for more than a few days - its snappy and the code completion works well.

Cheers,

Chris

4 comments

Hello Chris,

Sure. You can go to Settings | TODO and define additional patterns that will

get such highlighting.

I notice that pycharm highlights:

  1. TODO: something

comments automagically in bright blue which is very handy. Is this a

config options somewhere? As I would like it also to be able to

highlight # FIXME: # BUG: etc comments.

BTW, I love pycharm :-)

its the first Python IDE I've stuck with for more than a few days -

its snappy and the code completion works well.

--

Dmitry Jemerov

Development Lead

JetBrains, Inc.

http://www.jetbrains.com/

"Develop with Pleasure!"

1

Thanks. Unfortunatly that dosen't seem to work, infact pycharm is not highlighting TODO comments anymore either, shall I file a bug report? I recently upgraded to 96.243.

Is there a setting to turn it on / off? I do have the highlight configured in blue in the Editor settings.

Cheers,

Chris

0

Hello Chris,

The latest build of PyCharm is 96.477. Could you please upgrade to that and

check if it fixes things for you?

If it doesn't: in which file types is the TODO highlighting broken (Python,

HTML, anything else)?

Thanks. Unfortunatly that dosen't seem to work, infact pycharm is not

highlighting TODO comments anymore either, shall I file a bug report?

I recently upgraded to 96.243.

Is there a setting to turn it on / off? I do have the highlight

configured in blue in the Editor settings.

Cheers,

Chris

---

Original message URL:

http://devnet.jetbrains.net/message/5266631#5266631

--

Dmitry Jemerov

Development Lead

JetBrains, Inc.

http://www.jetbrains.com/

"Develop with Pleasure!"

0

Oops, thought I was already running the latest version.

96.477 fixes the problem for me, thank you.

0

Please sign in to leave a comment.