AppCode doesn't start simulator [solved]

Was doing some refactoring today in AppCode, including code changes and a new logical folder structure for all files.

When I was done, I couldn't run my code in the simulator.  Neither Debug or Run works, running it in quick succession just shows:
     Stopping previous simulator session...

I have no issues running the simulator in XCode (in either Run or with a Breakpoint set).

Any ideas what's causing the issue?  And how it could be solved in AppCode?

Thanks in advance!

p.s. running latest version of Appcode (3.1.2) and XCode (6.1.1)

Hi Johnathan,

Could you please try to do the following:
  1. restart AppCode
  2. if the problem will remain, please restart your Mac
  3. if these two steps won’t help please send us idea.log (you can use Help | Show Log in Finder)

Hi Anna

I tried restarting both AppCode & my Mac, but the furtherest I get is Simulator is started, but app is not launched.

Looking through the log you pointed to, I'm seeing a:
     com.intellij.execution.ExecutionException: E0210 12:24:12.925546 2018890512 ProtobufClient.cpp:103] ERROR, no such host as localhost

Is there an email address I could post the log to for further analysis by the JB team? As mentioned this issue is as recent as 3 days, AC was working perfectly fine before the refactor.




Please send full log to


Thanks Anna.  Problem solved - it was on my end.

For anyone else reading this that has virtual host set up (Apache), you need to have localhost mapped in your /etc/hosts, i.e:   localhost

I recalling playing around with this file last week - funny that XCode can still invoke the Simulator?


the same problem,

ERROR, no such host as localhost

but I see the path private/etc/hosts the content has   localhost


It has been resolved, my mistake is too low


I also said that before the old is not connected to the Apple store, the original is because the hosts file


Please sign in to leave a comment.