Is there any way to turn off anti-aliasing in PyCharm for OS X?

I've just been playing around with PyCharm and so far I'm really impressed. The only thing I see missing is the ability to turn off anti-aliasing on the fonts (I find coding with aliased fonts hard on the eyes).

I had the same problem with Komodo, and found a nice hack using Apple defaults:

defaults write com.activestate.Komodo AppleAntiAliasingThreshold 20

Is there a similar workaround for PyCharm, or is some other solution planned? I'd love to make the switch--this is really the only thing holding me back!

Thanks.

4 comments

Nevermind. I just found the option for it in preferences. Awesome!

0

Hello Ben,

Have you tried turning off Settings | Appearance | Use antialiased fonts?

I've just been playing around with PyCharm and so far I'm really

impressed. The only thing I see missing is the ability to turn off

anti-aliasing on the fonts (I find coding with aliased fonts hard on

the eyes).

I had the same problem with Komodo, and found a nice hack using Apple

defaults:

defaults write com.activestate.Komodo AppleAntiAliasingThreshold 20

Is there a similar workaround for PyCharm, or is some other solution

planned? I'd love to make the switch--this is really the only thing

holding me back!

--

Dmitry Jemerov

Development Lead

JetBrains, Inc.

http://www.jetbrains.com/

"Develop with Pleasure!"

0

I'm using OS X 10.5 and PyCharm (which seems great so far, btw).

I've noticed that when anti-aliasing is ON (my preference along with the excellent coding font Droid Sans Mono) the text in the editor appears much "thicker" or "bolder" when compared to other apps, which affects readability. I have anti-aliasing turned off for now, as that is a bit less distracting to read.

Is there any chance the anti-aliased text rendering can be fixed?

0

Hello Alvin,

The text rendering is done by the Apple JDK, and we don't have any specific

control over it. You can try playing with the VM options of the Apple JVM

(such as apple.awt.graphics.UseQuartz) to see if this gets better results

on your machine. The VM options are specified in Info.plist under the PyCharm.app

directory.

I'm using OS X 10.5 and PyCharm (which seems great so far, btw).

I've noticed that when anti-aliasing is ON (my preference along with

the excellent coding font Droid Sans Mono) the text in the editor

appears much "thicker" or "bolder" when compared to other apps, which

affects readability. I have anti-aliasing turned off for now, as that

is a bit less distracting to read.

Is there any chance the anti-aliased text rendering can be fixed?

--

Dmitry Jemerov

Development Lead

JetBrains, Inc.

http://www.jetbrains.com/

"Develop with Pleasure!"

0

Please sign in to leave a comment.