iOS 8 Simulator

This question isn't necessarily AppCode specific - it's related to XCode as well.... Since I've upgrated to XCode 6, I am unable to run my project in the new iPhone 6 simulator. AppCode provides the following error:

Simulator session failed with error: Unable to run app in Simulator
Couldn't create target

I am still able to run in the iOS 7 simulator without an issue.

Anyone else have this issue & know a solution?


The error I get in XCode is the following:

Screenshot 2014-09-22 13.50.20.png


Ryan, try clearing ~/Library/Developer/CoreSimulator/, ~/Library/Developer/Xcode/, and reinstalling Xcode from scratch.


I get the same issue on iOS8 simulator, Except it only happens when running as 'DEBUG' instead of 'Run' on iPhone 6:

Couldn't create target
Stopping simulator session...
Simulator session started with process 822

Process finished with exit code 0

@Anton, I'm hesitant to delete the folder because they also break XCode 6..

Is there a way to properly diagnose this issue and offer a solution that's non-intrusive?




Check contents of ~/Library/Logs/CoreSimulator/CoreSimulator.log for more information on the error.
You might also try to reset contents on simulator: iOS Simulator -> Reset Content and Settings, and reboot system.


Hi Tatiana

I've tried rebooting machine, and resetting Simulator Contents & Settings to no avail.

I get this error in the CoreSimulator.log file:

Oct  4 05:25:38 <my machine name>.local CoreSimulatorService[736] <Error>: Could not register service Failed to lookup 0x44e


I want to clarify the following re running in debug mode:

iphone 4s | iOS 8 - OK
iphone 5 | iOS8 - OK
iphone 5s | iOS 8 - error
iphone 6 | iOS 8 - error
iphone 6 plus | iOS 8 - error
iphone 4s | iOS 7 - OK
iphone 5 | iOS 7 - OK
iphone 5s | iOS 7 - error

Commonality seems to be with iphone 5s (either iOS 7 or iOS 8) or iphone 6 (iOS 8 only available option).

All leaving the following line in CoreSimulator.log:
<Error>: Could not register service Failed to lookup 0x44e

Any idea what's causing the issue??


5s and up are 64 bit devices


Hey Maarten, what's the implication?  I'm running AppCode on OSX with i7 processor.  OS is Maverick with the following kernel code.  It's all 64bit as far as I can tell, no??

Darwin Kernel Version 13.4.0: Sun Aug 17 19:50:11 PDT 2014; root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64


What are the 'Architectures', 'Valid Architectures', and 'Build Active Architecture Only ' project settings?

BTW, have you tried clearing AppCode's derived data folder in ~/Library/Caches/appCode30/DerivedData?


Hi Johnathan,

I don't claim the know what the answer is, I was just pointing out the first difference that came to mind between your working and failed tests.

As I understand things, the simulator runs an intel build of the actual iOS version, and this can be either a 32 or a 64 bit version.
This is independent of the fact that the underlying Mac OS X is 64 bit.


Maarten, it's definitely a good spot re the 64bit. Is there a setting that you know of in AppCode that could toggle between 32 & 64 bit iOS?  The same simulator versions failing in AppCode runs fine from XCode... Thanks!


Tatiana, are the architecture settings correct?
Screen Shot 2014-10-10 at 11.28.19 am.png

I've just cleared ~/Library/Caches/appCode30/DerivedData, still same issue...


Looks so.

Johnathan, I've created issue for your case. Please update it with AppCode/Xcode build information and attach idea.log (Help -> Show Log in Finder).
Also please specify what version of Xcode is selected in AppCode Preferences -> Tools (maybe you have several Xcode instances on the box).
AppCode is not supposed to do anything specific regarding architecture stuff - it uses the same mechanism as Xcode for building and running the app (bundled xcodebuild utility).


Thanks Tatiana.  I've updated the issue with the log


Please sign in to leave a comment.