URGENT HELP! How do I turn off the multiple caret thing

I've no idea how I turned it on, now I can't turn it off.. so now when I select using shift+arrows or mouse, it doesn't do normal text editor selection, it does a rectangle with redlines at the end (the multiple caret thing).

it's bascially rendered appcode useless to me.

how do I turn it off?!

7 comments

phew! got it.. column selection mode....

-22

Several useful shortcuts for the multiple carets:
- press Alt+Shift and select the caret locations with the mouse
- or press Ctrl+G to add the next occurrence of the current word to the selection
- to delete from the selection, press Ctrl+Shift+G.
- to restore single caret mode, use Esc.

-23

OMG REALLY!!  YOU CAME HERE ASKING FOR HELP AND THEN DIDN'T EXPLAIN HOW TO FIX IT!!!

THE SECOND PERSON CAME HERE WITH INSTRUCTIONS AND DIDN'T ANSWER THE QUESTION HOW TO TURN IT OFF!!!

WHAT IS WRONG WITH YOU PEOPLE!?

Toggling between line and column selection modes

To toggle between the line and the column selection modes, do one of the following:

  • On the main menu, choose Edit | Column Selection Mode.
  • On the context menu of the editor, choose Column Selection Mode.
  • Press Shift+Alt+Insert.

 

BURIED ON THIS PAGE: https://www.jetbrains.com/help/phpstorm/selecting-text-in-the-editor.html#column_selection

 Google searches that were unfruitful: webstorm free spacing (visual studio/MSWord calls it free spacing), webstorm turn off multi-caret, webstorm turn off column selection.  How is anyone supposed to find this setting?

 

 

46

Real LIFE-SAVER

SHIFT+ALT+INSERT did it for me. To toggle back to the normal mode.

To the world where only one cursor exists. Aight Bye.

4

Duz Duz Duz i got back to native selection THANKS...

-1

Please sign in to leave a comment.