AppCode-3.0 support for iOS-5.1?

Hello!

Is developing apps for iOS-5.1 supported in AppCode-3.0? I have some dependency problems.

First I tried:
MacOSX-10.7.4
Xcode-4.4.1
JDK-1.6.0_65 (The Apple version auto installed when installing AppCode)
AppCode-3.0

This resulted in:
10.7.4.png

Ok, so AppCode cannot run on 10.7 (strange in that it is a Java application and depends on the JVM).

Then I tried to upgrade to the lastest 10.8:
MacOSX-10.8.5
Xcode-4.4.1
JDK-1.6.0_65 (The Apple version auto installed when installing AppCode)
AppCode-3.0

But now I get:
10.8.5.png

This is a problem! I cannot upgrade Xcode to newer version because Xcode-4.4.1 is the latest version that supported iOS-5.1.

What are you guys doing to support the older iPad1 platform and what will be the correct combination for a working setup?

Best regards,
- Morten Green Hermansen, Fanitas

4 comments

Hi Morten,

mortengh wrote:
Ok, so AppCode cannot run on 10.7 (strange in that it is a Java application and depends on the JVM).

Actually, from what I recall seeing in the IntelliJ platform code (which AppCode is built on), there are quite a lot of things
that call out to native code, in order to create a better Mac-native experience.
JetBrains offerers the best Mac-native experience for a Java application that I have experienced.

This is a problem! I cannot upgrade Xcode to newer version because Xcode-4.4.1 is the latest version that supported iOS-5.1.

What are you guys doing to support the older iPad1 platform and what will be the correct combination for a working setup?

My own approach is to use the latest Xcode and SDK (I'm not sure if Apple actually requires that for app-store submissions
or merely recommends it).
I set the deployment target for the project to 5.1 (it actually offers even older versions, down to 4.3).

You'll need to put more emphasis on on-device testing, as the oldest simulator offered is 6.1.

My app isn't shipping yet, so there may be issues down the road that I've simply not run into yet.

Kind regards,
Maarten

0

Hello Maarten!

Thank you for your reply!
I totally agree on the great Mac experience of Idea!

You might be right about just dropping simulator support for the old devices and just testing on the actual device - it is just a bit sad. :-)
(As long as the new version of Xcode will generate code executeable on the old devices).

Best regards,
- Morten Green Hermansen, Fanitas

0

Maarten,

are you aware that Apple will refuse any app that was not built with XCode 5?

see https://developer.apple.com/ios7/ most important part follows:

Submit to the App Store


Use Xcode 5 with iOS 7 SDK to compile, validate, and submit  release versions of your iOS 7 apps to iTunes Connect. Starting February  1, new apps and app updates submitted to the App Store must be built  with Xcode 5 and iOS 7 SDK. For details on how to submit your app using  Xcode, review the App Distribution Guide and iTunes Connect Developer  Guide.

0

Morten,
We have dropped support for Xcode older than 5.0 due to great cost of it - each version of Xcode is different and thereore we have tons of conditional code. This make development, testing and supporting very expensive.
To be able to move forward as fast as we want, we decided to stop supporting older versions and focus on the latest stable Xcode instead.

We understant that in some situations it's absolutely must to test an app on, say, iOS Simulator 5.0. And there is a workaround: you can develop and do the most of the work in AppCode with the latest Xcode, and switch to older Xcode in order to test on various devices and simulators.

0

Please sign in to leave a comment.