appCode 2.5.5 not starting : stuck on splash screen

title says it all. After stopping  normally yesterday, when trying to restart appCode, i get the pretty splash screen forever, with AppCode burning 90% of one cpu core.  Can anyone help me figure out what is wrong, so i can continue my project (please :) ). I loathe the idea of returning to exCode even for one minute.

8 comments

The first thing I'd try is to remove the cache directory. AppCode will rebuild it once it starts up.
The cache directory is: ~/Library/Caches/appCode20

0

The entire directory ? it contains a bunch of sub directories , dont want to have ill side effects.

0

yes, the entire directory can be removed.
It does contain some things for local history, in case you need that, but most people using a version control system shouldn't need that.

If you want to be safe, just move the directory to somewhere else for safe keeping. That way you can always put it back if there's an issue.

0

Yves, have you manage to resolve the issue?

0

I tried the suggested answer, no result. It turns out that waiting 9 minutes !!! did the trick.

0

Have you taken a CPU snapshot by any change?

0

If you mean 'cpu snapshot' using AppCode builtins, the answer is no. GUI non responsive throughout the incident, and there was no menu to speak of. If there are other ways to do this from outside the process, let me know the recipe and i will do next time (hopefully not ever :) ).

0

Please take a jstack snapshot ( http://docs.oracle.com/javase/7/docs/technotes/tools/share/jstack.html ) when this happen again - we'll try to figure that out.

0

Please sign in to leave a comment.