Incorrect run configuration SDK 'iphoneos6.1' not found

I am new to AppCode, when you xcode this works fine. But in AppCode it can't find the SDK.

Can anyone help?

Thanks

5 comments

Hassan,
please check what Xcode is selected in AppCode | Preferences | Xcode. If it is Xcode 5, there is no iOS 6.1 SDK in it and you need to change the Base SDK in your build settings (File | Project Settings).

0

Thanks, it is Xcode 5 and I have manually added the 6.1 SDK, so it should work shouldn't it?

0

What do you mean by 'manually' adding SDK? If you installed a simualtor, you will be able to select in the the Run combobox, but still, the project will be build with iOS 7.0 SDK, bundled in Xcode 5.
BTW, please make sure that your projec thas the correct iOS Deployment Target set in the build settings.

0

I am having the same issue.  It is possible to copy the iOS SDK (6.1) manually into XCode 5 by opening the package contents in finder and copying in the SDK to go alongside 7.0 sdk.  In Xcode 5, I can then switch between 6.1 and 7.0 sdk in the build settings and the apps run fine either way (with the appropriate sdk).  If I run the same app from AppCode, it always runs with the 7.0 SDK regardless of the build setting.  Any advice?

0

Thanks for the update, please follow this bug report - we'll address it in one of the next updates.

0

Please sign in to leave a comment.