error running sphinx-build

Hi,

I'm trying to run sphinx from pycharm 1.5.2 to generate html documentation. I run "Run sphinx make targets" from Tools -> Restructured Text -> Sphinx actions, selected "html" from the menu and got the following error message:

make html

make: sphinx-build: No such file or directory

sphinx-build -b html -d _build/doctrees   . _build/html

make: *** [html] Error 1


Process finished with exit code 2

It's clear that Make is not finding sphinx-build when runing from Pycharm ("make html" runs without problem on the command line). The funny thing is that sphinx-quickstart runs fine on pycharm. Both sphinx-build and sphinx-quickstart are in the same directory:

[kroger@Chrysothemis ~]$ which sphinx-build
/usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7/bin/sphinx-build
[kroger@Chrysothemis ~]$ which sphinx-quickstart
/usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7/bin/sphinx-quickstart

I solved this problem for now by adding the full path for sphinx-build in my Makefile, but it'd be nice if Pycharm could find it by default (as it's finding sphinx-quickstart).
3 comments
Comment actions Permalink

Hi Pedro,

please file an issue to the our tracker http://youtrack.jetbrains.net/issues/PY

So we'll fix it in new release.

0

Please sign in to leave a comment.