Simulator versions

Hi.

I'm using the latest EAP (131.144) and I don't seem to find a way of doing the following:

I have installed iOS Simulator 5.0, 5.1, 6.0, 6.1 and 7.0. On AppCode, I only see:

iPhone retina (3.5 | 4 inches | 4 inches x64): iOS7
iPad (retina | non retina): iOS7

I'm missing two things:

* Non retina iPhone version
* iOS 5.0 til 7.0

I've checked after the simulator is open, and the versions and non retina iPhone are there. How can I make AppCode to see them?

3 comments

Edu,

the simulators are displayed basing on the 'iOS Deployment Target' build settings and version of Xcode.
Please first check that AppCode uses the latest release build of Xcode (which is 5A1413) in AppCode | Preferences | Xcode page.
Then, make sure the deployment target in the project is set to 5.0 and that Xcode offers the expected simulators.

If the problem remains, please file a bug report - we'll investigate and fix it asap.

0

There was no bug. I didn't notice that a) I only had the iOS 7.0 SDK installed (I swear I had more before installing Xcode 5, but maybe it was on another machine) and b) for iOS 7.0, there is no non-retina iPhone support.

Sorry about the confusion, and keep up the excellent work! :)

0

It looks like installing Xcode 5 wipes out previous simulators. I also had to re-install older versions.

0

Please sign in to leave a comment.