Project configured for Python 3.5, but PyCharm is checking for Python 2.7 package requirements

PyCharm 5.0.4 on OS X 10.11.4, with Python 3.5.1 and 2.7.11. Created a project on an existing directory with some code files. Configured Python 3.5.1 as the project interpreter. Created a new python file. Simply entered

__author__ = 'abc'

and PyCharm put up a warning

Package requirements 'python>=2.7.10', 'sklearn>=0.17', 'dateutil>=2.4' are not satisfied.

Why is PyCharm checking for package requirements in /usr/local/lib/python2.7?

How can I fix this?


- Peter

1 comment

Are you sure that these packages are missing in the wrong interpreter? Could you please post your requirements.txt or file here? 

Also it would help if you added line "#com.intellij.execution.configurations.GeneralCommandLine" in Help | Debug Log Setting and attached recorded idea.log here after this warning appeared again.


Please sign in to leave a comment.