Disable code completion when hitting tab?

Let's say I want to declare a variable like this:

float     mMyFloat;

After I type "float" a list box appears with code completion suggestions. As soon as I press the tab key, it selects the first suggested thing (which winds up never being "float", it's like "__FLOAT_H") which is pretty annoying. So I always have to hit ESC before hitting tab.

For the code completion options page I have the following:

Case sensitive completion: none
Autocomplete when only one choice: nothing selected
Sort lookup items lexicographically (checked)
Autopopup code completion in (ms): 0 (and checked)
Preselect the first suggestion: never
Insert selected variant by typing dot, space, etc. (unchecked)
Autopopup documentaion (ms): 1000 (and checked)
And both settings checked under the "Parameter info" section.

Is there a way to not auto complete when I hit tab? Thanks. I'm using AppCode 2.0.2 Build #OC-129.280

9 comments

Jeff,
it is most likely that the issue is caused by statistic and a related issue (OC-5945).
Can you please attach the screenshot of the completion list?
Also, try reproducing the problem on your code base with a clean settings (move ~/Library/Preferences/appCode20 to a safe place before experimenting and put it back when you are done) - does it recur?

0

Sorry for the late reply, I'm apparently not getting email notifications...

Attached is the screenshot showing the autocomplete list. When I use clean settings, the regular "float" is listed first.

Regardless of the suggestion order though, is there a reason it's autocompleting when I hit tab? I was under the impression that based on the settings I have enabled/disabled, that AppCode shouldn't be autocompleting when I press tab no matter what...



Attachment(s):
Screen Shot 2013-04-28 at 3.51.01 PM.png
0

Jeff,
completion with TAB is a standard 'always-on' behaviour.
Providing that the original problem with _FLOAT macro is s statistical issue, do you still want to diable TAB in completion? If yes, why?

BTW, to clear only the completion statistic, remove ~/Library/Caches/AppCode20/stats folder; this should be enough to reset all completion lists to the default state.

0

If nuking the stats folder will solve the problem then I suppose it's a moot point. My desire to disable tab completion was to get around any code completion bugs. I'll give it a go tomorrow and see if it works. Thanks!

0

So I just deleted that stats folder....and it doesn't fix the problem. I'm still getting the wrong float completion along with int and a few others as well. Anything else I should try to reset? I'd be loathe to nuke my entire settings file and have to reconfigure everything from the start.

0

For a low cost test, you can always move/rename the current settings directory to test something, and then move it back later to restore your settings.
Just do the moves with AppCode shut down.

0

Ya, I've done that before and it does indeed result in the problem going away (no erroneous autocompletes), but the problem is that if I keep it that way I of course have to reset everything which takes quite a bit of time. Since deleting the "stat" folder didn't solve the problem, I'm assuming it lies in some other file....

0

OK so I tried disabling the option "Sort lookup items lexicographically" and that seems to fix the issue.

0

Thanks for the issue description, I've created a YouTrack request for it: http://youtrack.jetbrains.com/issue/IDEA-106583 which you can watch/vote

0

Please sign in to leave a comment.