Change interactive console version

Hello,

Is there a way to change what version of Python is used for the interactive console in PyCharm?  I have both 2.7 and 3.2 installed, and would like to be able to select which console is used.

Thanks

5 comments

In PyCharm 2.0, you can select the interpreter used for the console under Settings | Console.


0

No you can't. I am having the same issue as well.

I have 2.7 installed but it is automatically picking 3.1 as a default (not sure where it is getting that from) and there is no picker tool, just a dropdown pointing you to 3.1pycharm.png

I even tried messing with the env variable but that seems to have no effect on it too.

How can I get PyCharm to use python.exe in my 2.7 installation?

Thanks



Attachment(s):
pycharm.png
0

Yes you can. The full list of interpreters known to PyCharm is defined under Settings | Python Interpreters.

0

YES, I can.

Did not explore this option in the settings.

Thanks for setting me straight, now I can actually use PyCharm.

0

Please sign in to leave a comment.