PyCharm Django - How to stop it from wrapping on "."

Hey Guys,

Is there a way to have "Enable right margin is not exceeded" (Project Settings > Python > Wrapping and Braces ) and have it NOT break on ".".  For example - this is currently happening and I don't like or want it..  That said I'm amazed at how intelligent it really is with this feature.

                log.error("We are unable to match an address for Company %s (%s%%)" % (self

                                                                                       .name,

This also occurs in HTML templates which is even more annoying...  So I just turned off wrapping in HTML.

Thanks!

1 comment
Comment actions Permalink

Right now there is no configuration for automatic wrapping. A feature request is welcome at http://youtrack.jetbrains.net/

0

Please sign in to leave a comment.