PyCharm ignores my breakpoints

Hi,

lately my PyCharm has been ignoring breakpoints, here is some info:

/opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin/python2.6 /Applications/PyCharm 1.5.3.app/helpers/pydev/pydevd.py --client 127.0.0.1 --port 55475 --file /Applications/GoogleAppEngineLauncher.app/Contents/Resources/GoogleAppEngine-default.bundle/Contents/Resources/google_appengine/dev_appserver.py --datastore_path=/Users/flapan/src/DataStore/dev_appserver.datastore --admin_console_server= --port 8082 .
pydev debugger: starting
Connected to pydev debugger (build 107.386)

Running an Mac OSX 10.6.8

Not really sure when it worked last. Any help is much appreciated.

Thanks

Mikkel

5 comments
Comment actions Permalink

Hi Mikkel,

Could you please describe where were breakpoints placed in your code?

Also if it is possible please install newest PyCharm build, set up environment variable PYCHARM_DEBUG=True in your AppEngine run configuration, try to place breakpoint and then attach console output to issue http://youtrack.jetbrains.net/issue/PY-5521

0
Comment actions Permalink

Hi,

problem momentarily went away. I had tried restarting PyCharm but that did not work I had tried deleting all .pyc files in the project that did not work. What did work was a total shutdown of my laptop, after that breakpoints were again acknowleged.

Going to try the suggested actions mentioned above and will report back then.

/Mikkel

P.S.: Breakpoints were placed in function calls that I knew I would pass.

Message was edited by: Mikkel Gadegaard

0
Comment actions Permalink

Upgraded PyCharm to 1.5.4 and posted console output to issue.

Edit:

I have a breakpoint on the first line of the Get Method in index.py

0
Comment actions Permalink

Any news on this issue it is extremely annoying :-(

0
Comment actions Permalink

I've also had PyCharm miss breakpoints, frequently.

For all of its builtin tools, I love PyCharm, but for straight-up debugging, I actually fire up Wing and use its debugger.

0

Please sign in to leave a comment.